Задать вопрос
29 декабря, 22:14

Дана

последовательность ненулевых вещественных чисел, за которой следует 0 (0 -

признак конца последовательности). Последовательность является оценками

студентов группы по одной дисциплине. Определить сколько "2" и " 5".

+1
Ответы (1)
  1. 30 декабря, 00:14
    0
    Var a:real; k2, k5:integer;

    begin

    k2:=0; k5:=0;

    read (a) ;

    while a0 do begin

    if a=2 then k2:=k2+1

    else if a=5 then k5:=k5+1;

    read (a) end;

    write (k2,' ', k5)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность ненулевых вещественных чисел, за которой следует 0 (0 - признак конца последовательности). Последовательность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность ненулевых вещественных чисел х, за которой следует 0 (0 - признак конца последовательности) ... Найти минимум из чисел sin (х).
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
Дана последовательность не более N ненулевых целых чисел, последним числом в последовательности является 0. Ввести эту последовательность в одномерный массив и вычислить хаpактеристики . Найти порядковые номера и сумму двух наибольших элементов.
Ответы (1)