Задать вопрос
9 сентября, 05:14

Дан фрагмент программы. После выполнения фрагмента программы определите значение Х.

A : = 16

B : = 4

B : = A - 2 * B

если A > B

то X : = A - B/4

иначе X : = B/14 - A

+2
Ответы (2)
  1. 9 сентября, 05:29
    0
    B = 16 - 2*4 = 8, далее выполняется условие А>B (16>8), то

    x = 16 - 8/4 = 14
  2. 9 сентября, 09:11
    0
    На языке Pascal код будет выглядеть так:

    var a: integer; b, x: real;

    begin

    a : = 16;

    b : = 4;

    b : = a - 2 * b;

    if a > b then x : = a - b / 4 else x : = b / 14 - a;

    writeln (x) ;

    end.

    При выполнении этой программы, получаем ответ равный 14.

    Т. к. b = 16 - 2 * 4 = 8, x = 16 - 8 / 4 = 16 - 2 = 14.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан фрагмент программы. После выполнения фрагмента программы определите значение Х. A : = 16 B : = 4 B : = A - 2 * B если A > B то X : = A ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы