Задать вопрос
21 августа, 03:49

Дан массив, состоящий из 20-ти целых чисел. Выяснить, на сколько максимальный элемент превосходит минимальный: 3

помогите, котаны: 3

нужна программа в паскале

+2
Ответы (1)
  1. 21 августа, 07:17
    0
    Var a:array [1 ... 20] of integer; i, max, min, r:integer;

    begin

    max:=0; min:=24000;

    for i:=1 to 20 do

    readln (a[i]) ;

    for i:=1 to 20 do

    if a[i]
    for i:=1 to 20 doif a[i]>max then max:=a[i];

    r:=max-min;

    writeln;

    writeln (r) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив, состоящий из 20-ти целых чисел. Выяснить, на сколько максимальный элемент превосходит минимальный: 3 помогите, котаны: 3 нужна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык Паскаль. №1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, оканчивающиеся на цифру k. №2 Дан масив целых числ. Найти в этом массиве минимальный элмент m и максимальный M.
Ответы (1)
Задачи на массив (паскаль) : Массив (подсчёт суммы) а) Дан массив целых чисел. Найти сумму нечётных элементов. б) Дан массив. Определить максимальный и минимальный элемент.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Паскаль! Заполните массив случайными числами и найти минимальный и максимальный элементы массива и их номера. Пример: Массив: 1 2 3 4 5 Минимальный элемент: A[1]=1 Максимальный элемент: A[5]=5
Ответы (1)
Заполнить массив случайными числами и найти минимальный и максимальный элементы массива и их номера Пример: Массив: 1 2 3 4 5 Максимальный элемент: А[1]=1 Минимальный элемент: А[5]=5 10 класс
Ответы (1)