Задать вопрос
22 декабря, 21:10

сформировать массив с помощью Random от - 30 до 30. Размер 10 элементов. Сколько в массиве отрицательных элементов?

+1
Ответы (1)
  1. 22 декабря, 22:59
    0
    Begin

    randomize;

    for i:=1 to n do

    a[i]:random (60) - 30;

    k:=0;

    for i:=1 to n do

    if a[i]<0 then k:=k+1;

    writeln ('k=', k) ;

    end.

    язык программирования - Pascal, k - количество отрицательных элементов
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «сформировать массив с помощью Random от - 30 до 30. Размер 10 элементов. Сколько в массиве отрицательных элементов? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Необходимо вывести числа от - 3 до 7. random (6) ; random (-3,7) ; random (-3) + 7; random (7) - 3.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Дан массив, содержащий N элементов и заполненный случайными числами от - 10 до 9. Сформировать новый массив из значений элементов, стоящих на четных местах. Подсчитать количество отрицательных и положительных значений элементов в новом массиве.
Ответы (2)
составить программу 1) найти сумму всех элементов массива (1 до10) random. 2) сформировать массив из положительных и отрицательных элементов от - 10 до 30. найти кол-во положит и отриц элементов. найти сумму положит и произведение отриц.
Ответы (1)