Задать вопрос
8 апреля, 20:41

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен произведению соответствующего элемента исходного массива и заданного с клавиатуры числа А. В проученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные полученные результаты.

+5
Ответы (1)
  1. 8 апреля, 23:49
    0
    Var

    m, n: array [1 ... 15] of integer;

    a, i, max: integer;

    begin

    readln (a) ;

    writeln ('Исходный массив:') ;

    for i: = 1 to 15 do

    begin

    m[i]: = random (20) ;

    n[i]:=m[i]*a;

    if (n[i]>max) and (i mod 2=1) then max:=n[i];

    write (m[i],' ') ;

    end;

    writeln;

    writeln ('Новый массив:') ;

    for i: = 1 to 15 do write (n[i],' ') ;

    writeln;

    writeln ('Максимальный нечетный: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. получите новый масив, каждый элемент которого равен среднему арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа А.
Ответы (1)
1 Задание: сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу: 1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса;
Ответы (1)
1. сформируйте массив содержащий 10 элементов с помощью датчика случайных чисел получить новый массив, каждый элемент которого равен сумме соответствующего элемента и его номера исходного массива. 2.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Сформулируйте массив, содержащий 15 элементов, с помощью датчика случайн ых чисел. получите новый массив, каждый элемент которого равен обратному соответствующему элементу исходного массива.
Ответы (1)