Задать вопрос
1 февраля, 18:56

найти произведение всех элементов массива целых чисел меньших 0 размер массива равен-10

+4
Ответы (1)
  1. 1 февраля, 21:30
    0
    Program n1;

    Uses Crt;

    var a:array[1 ... 10] of integer;

    s, i: integer;

    begin

    for i:=1 to 10 do begin

    a[i]:=random (11) - 5;

    writeln (a[i]:4) ;

    end;

    s:=1;

    for i:=1 to 10 do

    if (a[i]<0) then s:=s*a[i];

    writeln ('Proizvedenie vseh otricat chisel: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти произведение всех элементов массива целых чисел меньших 0 размер массива равен-10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)