Задать вопрос
12 декабря, 10:29

Вводится n. найти произведение натуральных чисел от 1 до n. 3 способами (циклами) для PaskalABC.

+1
Ответы (1)
  1. 12 декабря, 12:12
    0
    1 способ:

    var n, i, pr:integer;

    begin

    read (n) ;

    pr:=1;

    if (n>=1) then

    begin

    for i:=1 to n do

    begin

    pr:=pr*i;

    end;

    end else

    writeln ('Неправильный ввод') ;

    writeln (pr) ;

    end.

    2 способ:

    var n, i, pr:integer;

    begin

    read (n) ;

    pr:=1;

    if (n>=1) then

    begin

    for i:=1 to n do

    begin

    pr*=i;

    end;

    end else

    writeln ('Неправильный ввод') ;

    writeln (pr) ;

    end.

    3 способ:

    var n, i:integer;

    function fact (n:integer) : integer;

    begin

    if n=1 then fact:=1

    else fact:=fact (n-1) * n;

    end;

    begin

    read (n) ;

    i:=fact (n) ;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится n. найти произведение натуральных чисел от 1 до n. 3 способами (циклами) для PaskalABC. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Напишите программу в PaskalABC, которая в последовательности натуральных чисел определяет максимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
помогите решить. Всё в с++, для code blocks. 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)