Задать вопрос
5 августа, 11:40

Дано два одномерных массива разной длины a (n) и b (m). Сформировать двумерный массив C (n * m), так, что бы каждый элемент матрицы был равен:

cij = ai + b j

+5
Ответы (1)
  1. 5 августа, 15:01
    0
    program chik;

    var a, b:array[1 ... 1000]of longint;

    c:array[1 ... 1000,1 ... 1000]of longint;

    n, m, i, j:longint;

    begin

    read (n, m) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    end;

    for i:=1 to m do

    begin

    read (b[i]) ;

    end;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    c[i, j]:=a[i]+b[j];

    end;

    end;

    for i:=1 to n do

    begin

    for j:=1 to m do

    begin

    write (c[i, j]:3,' ') ;

    end;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано два одномерных массива разной длины a (n) и b (m). Сформировать двумерный массив C (n * m), так, что бы каждый элемент матрицы был ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
1. Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить: последовательно переписать в другой массив отрицательные элементы начального массива. с применение подпрограмм и процедур желательно
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
Даны два одномерных массива разной размерности. Для каждого из заданных одномерных массивов выполнить преобразование массива так: все его элементы, большие девяти заменить числом девять, все его элементы, меньшие пяти заменить числом пять, а все
Ответы (1)