Задать вопрос
27 февраля, 15:07

в двух файлах записано по 10 чисел, создать третий файл, в котором чередуются числа первых двух файла. Написать в программе PascalABC

+4
Ответы (2)
  1. 27 февраля, 15:54
    0
    Var

    input1, input2, output : Text;

    i, number : integer;

    begin

    AssignFile (input1, 'input1. txt') ;

    AssignFile (input2, 'input2. txt') ;

    AssignFile (output, 'output. txt') ;

    Reset (input1) ;

    Reset (input2) ;

    Rewrite (output) ;

    for i : = 1 to 10 do

    begin

    read (input1, number) ;

    write (output, number, ' ') ;

    read (input2, number) ;

    write (output, number, ' ') ;

    end;

    CloseFile (input1) ;

    CloseFile (input2) ;

    CloseFile (output) ;

    writeln ('Готово') ;

    end.
  2. 27 февраля, 16:29
    0
    Var

    f1, f2 : array [1 ... 10] of integer;

    i : integer;

    input, output : text;

    begin

    assign (input,'input1. txt') ;

    reset (input) ;

    for i: = 1 to 10 do

    read (input, f1[i]) ;

    close (input) ;

    assign (input,'input2. txt') ;

    reset (input) ;

    for i: = 1 to 10 do

    read (input, f2[i]) ;

    close (input) ;

    assign (output,'output. txt') ;

    rewrite (output) ;

    for i: = 1 to 10 do

    begin

    writeln (output, f1[i]) ;

    writeln (output, f2[i]) ;

    end;

    close (output) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «в двух файлах записано по 10 чисел, создать третий файл, в котором чередуются числа первых двух файла. Написать в программе PascalABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У нас есть. bat файл. Если прописать: echo [Команда]>[Место сохранения]/Имя файла echo [Команда]>[Место сохранения]/Имя файла Имя файла одинаковое в двух случаях, но при запуске этого файла, создается бат файл и эти две (Или больше) команды
Ответы (1)
Дан текстовый файл с именем input. txt в первой строке которого записано натуральное число N, а во второй строке N целых чисел. Переписать в файл с именем a. dat числа, кратные 100 из исходного файла, а в файл с именем b.
Ответы (1)
Когда используется команда меню Файл - Сохранить Выберите один из 3 вариантов ответа: 1) Когда мы хотим сохранить файл и при этом оставить исходный вариант файла 2) Когда мы хотим сохранить файл и при этом он перезапишет исходный вариант файла 3)
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)