Задать вопрос
3 мая, 04:42

Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива

+4
Ответы (1)
  1. 3 мая, 08:33
    0
    Если паскаль, то -

    const n:=100; / / в массиве пусть будет 100 элементов

    var tarray:array[1 ... n] of integer;

    max:integer;

    i:=byte;

    begin

    {тут заполнение массива}

    max:=tarray[1]; / / думаем что максимум - это первый элемент

    for i:=1 to n do

    if max > tarray[i]

    then max:=tarray[i]; //если встречаем элемент больше максимального - то он - новый максимальный

    write ('Максимальный элемент - ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан одновременный массив, состоящий из 10 эллементов. Пользователь вводит элементы массива. Ввести массив на экран в строку. Найти минимальный элемент массива.
Ответы (1)