Задать вопрос
26 сентября, 16:27

Найдите наибольший общий делитель двух чисел. Или для цикла (пока), или для цикла (до) в паскале.

+5
Ответы (1)
  1. 26 сентября, 19:32
    0
    Var a, b, answer: integer;

    function gcd (m, n: integer) : integer;

    var modulo: integer;

    begin

    modulo : = m mod n;

    if modulo = 0 then gcd : = n

    else gcd : = gcd (n, modulo) end;

    begin

    write ('Введите 2 числа: ') ; readln (a, b) ;

    answer : = gcd (a, b) ;

    writeln ('Наибольший общий делитель: ', answer) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите наибольший общий делитель двух чисел. Или для цикла (пока), или для цикла (до) в паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
Дан оператор цикла. определить, при каких значениях переменной x а) тело цикла не будет выполнено ни разу б) тело цикла будет выполнено ровно один раз в) произойдёт зацикливание нц пока х
Ответы (1)
Проанализируйте работу программы. program math; var x, y: integer; begin x:=1; y:=1; while x
Ответы (1)