Задать вопрос
9 ноября, 18:13

С помощью Паскаля: Число в двоичной системе счисления, введенное

пользователем программы, преобразовать в десятичное число.

Используя цикл! Желательно попроще (без length, ord, exp).

+4
Ответы (1)
  1. 9 ноября, 18:49
    0
    var

    a, b, i: integer;

    d: string;

    begin

    readln (a) ;

    d : = a. ToString () ;

    for i : = length (d) downto 1 do

    b + = byte. Parse (d[i]) * round (power (2, length (d) - i)) ;

    writeln (b) ;

    end.

    Незя без length, нерационально
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С помощью Паскаля: Число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число. Используя цикл! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
Паскаль. Число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число. Результат вывести на экран.
Ответы (1)
Написать программу в PascalABC! Число в двоичной системе счисления, введенное пользователем программы, преобразовать в десятичное число.
Ответы (1)