Задать вопрос
18 мая, 01:16

Составте программу на Pascal.

Сколько существует (невырожденных) треугольников периметра N с целыми длинами сторон? (Треугольник со сторонами a, b, c называется невырожденным, если из отрезков длины a, b, c его можно составить.)

Входные данные. С клавиатуры вводится число N (1<=N<=1000)

Выходные данные. Программа выводит число таких треугольников.

+5
Ответы (1)
  1. 18 мая, 04:55
    0
    Uses crt;

    var a, b, c, k, n:integer;

    Begin

    clrscr;

    Write ('n=') ; readln (n) ;

    k:=0;

    for a:=1 to n do

    for b:=a to n do

    for c:=b to n do

    if (c
    writeln (k,' treugolnikov') ;

    writeln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу на Pascal. Сколько существует (невырожденных) треугольников периметра N с целыми длинами сторон? (Треугольник со ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько существует невырожденных треугольников периметра с целыми длинами сторонТреугольник со сторонами называется невырожденным если из отрезков длины его можно составить Входные данные С клавиатуры вводится число Выходные данные Программа выводит
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)