Задать вопрос
13 марта, 20:53

Дан текст. определить количество цифр в нём

+2
Ответы (1)
  1. 13 марта, 21:25
    0
    var

    i, count:integer;

    str:string;

    begin

    readln (str) ;

    for i:=1 to length (str) do begin

    if (ord (str[i]) > = 48) and (ord (str[i]) < = 57) then inc (count) ;

    end;

    writeln ('Количество цифр = ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан текст. определить количество цифр в нём ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Дано натуральное число. Определить: 1) Определить количество повторений заданной цифры в нем 2) Сколько раз в нем встречается цифра, равная последней 3) Количество четных цифр в нем. желательно в Basic. но можно и паскаль
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)