Задать вопрос
26 сентября, 03:41

1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20, выводит числа на экран и вычисляет их сред арифм.

2. напишите прог, в которой осуществляется ввод целых чисел, до тех пор, пока не будет введен 0 и определено максимальное из введенных чисел

+5
Ответы (1)
  1. 26 сентября, 05:41
    0
    Задача 1

    Var i, sum:integer;

    mas:array [1 ... 10] of integer;

    Begin

    for i:=1 to 10 do begin

    mas[i]:=random (20) ;

    write (' ', mas[i]) ;

    sum:=sum+mas[i];

    end;

    writeln;

    write ('Среднее арифметическое этих чисел = ', sum/10) ;

    End.

    Задача 2

    Var i, max:integer;

    Begin

    readln (i) ;

    while (i0) do begin

    if (i>max) then max:=i;

    readln (i) ;

    end;

    Writeln ('Максимальное число: ', max) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20, выводит числа на экран и вычисляет их сред арифм. 2. напишите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел. используйте оператор repeat.
Ответы (1)
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)