Задать вопрос
20 июня, 06:52

В интервале [2; n ] найти натуральное число с максимальной суммой делителей.

+1
Ответы (2)
  1. 20 июня, 07:08
    0
    Program Natur;

    Uses Crt;

    Var a, Summa, n : integer;

    Begin

    Clrscr;

    write ('N=') ;

    readln (N) ;

    {Цикл с предусловием}

    a:=2;

    Summa:=0;

    while a<=N do

    begin Summa: = Summa + a; a : = a + 1 end;

    Writeln (' Результат первого суммирования:', Summa) ;

    {Цикл с постусловием}

    а:=1;

    Summa:=0;

    repeat Summa:=Summa + а; а:=а+1 until a>N;

    Writeln

    (' Результат второго суммирования:', Summa) ;

    {Цикл с параметром} Summa:=0;

    for а : = 2 to N do Summa : = Summa + a;

    Writeln (' Результат третьего суммирования:', Summa) ; End
  2. 20 июня, 10:25
    0
    Vivdarkbloom, к сожалению, нашел сумму всех чисел от 2 до N, а не число с

    максимальной суммой делителей. Надо было так, пишу на Visual Basic

    Sub Command1_Click ()

    Rem Программа запускается по нажатию кнопки Command1 на форме

    Dim n As Integer, Summa As Integer, Max As Integer

    Dim Maxn As Integer, i As Integer, k As Integer

    n = Text1. Text ' Это текстовое поле на форме, куда вводится n

    Max = 1: Maxn = 1

    For i = 2 To n

    Summa = 0

    For k = 1 To i

    If i Mod k = 0 Then Summa = Summa + k ' Если k - делитель i, то прибавляем

    Next k

    If Summa > Max Then ' Если сумма больше максимальной

    Max = Summa ' Сохраняем сумму

    Maxn = i ' И сохраняем число i.

    End If

    Next i

    Text2. Text = Maxn ' Это второе текстовое поле, куда выводится результат

    End Sub
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В интервале [2; n ] найти натуральное число с максимальной суммой делителей. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Найдите ошибку. (выводит просто большее число) Найти натуральное число из интервала от a до b с максимальной суммой делителей.
Ответы (1)
Дано натуральное число N. Найти и вывести все числа в интервале от 1 до N - 1, у которых произведение всех цифр совпадает с суммой цифр данного числа. Если таких чисел нет, то вывести слово "Нет"
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)