Задать вопрос
26 сентября, 06:08

Имеется прямоугольное отверстие со сторонами a и b и кирпич с рёбрами x, y z. Требуется составить условие прохождения кирпича в отверстие. (Программный код нужно писать в Паскале)

+1
Ответы (1)
  1. 26 сентября, 07:50
    0
    Коробки

    (Время: 1 сек. Память: 16 Мб Сложность: 19%)

    На столе лежат коробка размера A1 * B1 * C1 и коробка размера A2 * B2 * C2. Выясните можно ли одну из этих коробок положить в другую, если разрешены повороты коробок вокруг любого ребра на угол 90 градусов.

    Входные данные

    Первая строка входного файла содержит три целых числа A1, B1 и C1. Вторая строка входного файла содержит три целых числа A2, B2 и C2. Все числа положительны и не превосходят 1000.

    Выходные данные

    Если коробки одинаковы, выведите "Boxes are equal". Если первая коробка может быть положена во вторую, выведите "The first box is smaller than the second one". Если вторая коробка может быть положена в первую, выведите "The first box is larger than the second one". Иначе, выведите "Boxes are incomparable"

    program gt;

    label 1;

    var a, b:array[1 ... 1000]of longint;

    a1, b1, c1, a2, b2, c2, p, l, n, i, j:longint;

    begin

    read (a1, b1, c1, a2, b2, c2) ;

    a[1]:=a1; a[2]:=b1; a[3]:=c1;

    b[1]:=a2; b[2]:=b2; b[3]:=c2;

    for i:=1 to 2 do

    begin

    for j:=1 to 3-i do

    begin

    p:=A[j]; l:=A[j+1];

    if A[j]>A[j+1] then begin

    A[j]:=l;

    A[j+1]:=p;

    end;

    end;

    end;

    for i:=1 to 2 do

    begin

    for j:=1 to 3-i do

    begin

    p:=b[j]; l:=b[j+1];

    if b[j]>b[j+1] then begin

    b[j]:=l;

    b[j+1]:=p;

    end;

    end;

    end;

    if (a[1]=b[1]) and (a[2]=b[2]) and (a[3]=b[3]) then begin

    writeln ('Boxes are equal') ;

    goto 1;

    end;

    if ((a[1]<=b[1]) and (a[2]
    ((a[1]
    ((a[1]<=b[1]) and (a[2]<=b[2]) and (a[3]
    writeln ('The first box is smaller than the second one') ;

    goto 1;

    end;

    if ((a[1]>=b[1]) and (a[2]>b[2]) and (a[3]>=b[3])) or

    ((a[1]>=b[1]) and (a[2]>=b[2]) and (a[3]>b[3])) or

    ((a[1]>b[1]) and (a[2]>=b[2]) and (a[3]>=b[3])) then begin

    writeln ('The first box is larger than the second one') ;

    goto 1;

    end;

    writeln ('Boxes are incomparable') ;

    1:

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеется прямоугольное отверстие со сторонами a и b и кирпич с рёбрами x, y z. Требуется составить условие прохождения кирпича в отверстие. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a, b, c, пройти через прямоугольное отверстие со сторонами x и y (при этом стороны параллелепипеда параллельны сторонам отверстия).
Ответы (1)
1. Найти разность 31 (10) - 16 (10) в восьмибитном представлении. Прямой код, обратный код и дополнительный код. 2. Представить число - 292 (10) в двоичном виде в шестнадцатибитном представлении в формате целого со знаком.
Ответы (1)
Даны положительные числа a, b, c, x. Выясните, пройдёт ли кирпич с рёбрами a, b, c в квадратное отверстие со стороной x. Решить в паскале
Ответы (1)
в стене имеется прямоугольное отверстие с длинами сторон X и y. При каком условии труба, сечением которой является круг радиуса R, пройдет в это отверстие, если длина трубы превышает x+y?
Ответы (1)
вычислить значение для функции В=А+С^2, если в=2, а значение С изменяется на отрезке от 1 до 10, с шагом 0,5 (составить программный код в паскале)
Ответы (2)