Задать вопрос
12 октября, 00:08

Паскаль. массивы

В линейном массиве целых чисел b (40) заменить первые 10 элементов по формуле: b[i]=b[i]*3

+3
Ответы (1)
  1. 12 октября, 03:21
    0
    Program gt;

    var b:array[1 ... 40]of integer;

    i:integer;

    begin

    randomize;

    for i:=1 to 40 do

    begin

    b[i]:=random (100) ;

    if (i<=10) then b[i]:=b[i]*3;

    write (b[i],' ') ;

    end;

    end.

    2)

    задается с клавиатуры

    program gt;

    var b:array[1 ... 40]of integer;

    i:integer;

    begin

    for i:=1 to 40 do

    begin

    read (b[i]) ;

    if (i<=10) then b[i]:=b[i]*3;

    end;

    for i:=1 to 40 do

    write (b[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. массивы В линейном массиве целых чисел b (40) заменить первые 10 элементов по формуле: b[i]=b[i]*3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Подпрограммы, Pascal ABC Дано массивы А1 (N1, M1), A2 (N2, M2), A3 (N3, M3). Сформировать одномерные массивы В1, В2, В3, каждый из которых состоит из 2-ух элементов.
Ответы (1)