Задать вопрос
31 июля, 20:22

За один ход с числом делается операция вида: если число не делится на 3, то вычетаем 1 а если делится, то делим на 3. Так из числа 39 единица получается за 5 таких ходов (имеется в виду цепочка, 39-13-12-4-3-1)

Программа должна:

-Запросить число ходов k (натуральное число, 0<=k<=37)

-Найти и вывести на экранНаименьшее натуральное число, которое превращается в единицу за k таких ходов.

Язык программы Pascal АВС.

+5
Ответы (1)
  1. 31 июля, 21:15
    0
    Есть =)

    program z;

    var k, x, i: integer;

    begin

    readln (k) ;

    x:=1;

    for i:=1 to k do

    begin

    if ((x + 1) mod 3 = 0) then x:=x*3

    else x:=x+1;

    end;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «За один ход с числом делается операция вида: если число не делится на 3, то вычетаем 1 а если делится, то делим на 3. Так из числа 39 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)
Программа для Pascal abc Запросить два числа затем запросить их произведение если пользователь ошибся повторить запрос
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Выключить монитор Ход работы: Отсоединить монитор от компьютера Ход работы: Отсоединить мышь и клавиатуру Ход работы: Отсоединить все остальные имеющиеся внешние устройства кабеля Ход работы: Подключить к компьютеру монитор Ход работы: Подключить к
Ответы (1)