Задать вопрос
11 октября, 01:54

В массиве подсчитать: количество положительных и количество чётных чисел вместе. (Элементов массива: 24. Массив вводится случайным образом в интервале [-6; 13])

+5
Ответы (1)
  1. М
    11 октября, 05:35
    0
    На обычном паскалеАБЦ

    var a:array[1 ... 24] of integer; k, i:integer;

    begin

    k:=0;

    for i:=1 to 24 do read (a[i]) ;

    for i:=1 to 24 do if (a[i]>0) and (a[i] mod 2=0) then k:=k+1;

    write (k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве подсчитать: количество положительных и количество чётных чисел вместе. (Элементов массива: 24. Массив вводится случайным образом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
 
Войти
Задать вопрос