Задать вопрос
28 августа, 01:29

Напишите программу удаляющая из текста все буквы совпадающие с его последней буквой

+4
Ответы (2)
  1. 28 августа, 04:40
    0
    Var s:string; i:integer;

    begin

    read (s) ;

    i:=1;

    while i
    if s[i]=s[length (s) ] then s:=copy (s, 1, i-1) + copy (s, i+1, length (s) - i)

    else i+=1;

    write (s)

    end.
  2. 28 августа, 05:16
    0
    Uses crt;

    var s:string;

    n, i:integer;

    begin

    readln (s) ;

    n:=length (s) ;

    for i:=1 to n do

    if s[i]=s[n] then delete (s, i, 1) ;

    writeln (s) ;

    end.

    Эта программа рассчитана на то, что удаляется и последний символ тоже
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу удаляющая из текста все буквы совпадающие с его последней буквой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)
Напишите программу, позволяющую по последней цифре трехзначного числа определить последнюю цифру его произведения на число 3 (например, для числа 234, последней цифрой при произведении на 3 будет цифра 2)
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Паскаль! Написать программу, в которой по последней цифре числа определить последнюю цифру его квадрата и последнюю цифру его куба. Для определения последней цифры числа применить операцию MOD (получение остатка от деления).
Ответы (1)