Задать вопрос
21 ноября, 07:13

на паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел

+4
Ответы (2)
  1. 21 ноября, 08:21
    0
    Program test;

    const n = 10;

    var i, k:integer;

    m: array[1 ... n] of integer;

    begin

    for i:=1 to n do

    begin

    write (' Введите [', i,'] член масива: ') ;

    readln (m[i]) ;

    end;

    for i:=1 to n do if m[i]<0 then inc (k) ;

    writeln ('Количество чисел меньших нуля : ', k) ;

    end.
  2. 21 ноября, 10:32
    0
    Var a, i:integer;

    var arrayx = array[0 ... 10] of integer;

    begin

    arrayx[0] = - 1;

    arrayx[1] = 3;

    arrayx[2] = 5;

    arrayx[3] = - 3;

    arrayx[4] = - 2;

    arrayx[5] = - 7;

    arrayx[6] = 2;

    arrayx[7] = 3;

    arrayx[8] = - 10;

    arrayx[9] = 0;

    for i : = 1 to 10 do

    begin

    if (arrayx[i] < 0) a: = a + 1;

    end;

    writeln ("Отрицательных чисел: ", a) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «на паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На Паскале. Задан массив из N действительных чисел (N может быть задано не более 25). Отрицательные числа в заданном массиве упорядочить по убыванию их значений. Взаимное расположение отрицательных и положительных чисел сохранить.
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
В произвольно заданном одномерном1. В произвольно заданном одномерном массиве (случайные значения из отрезка - 4 до 10) из 13 элементов, определить минимальный элемент и его номер. 2.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. В произвольно заданном одномерном массиве (случайные значения из отрезка - 6 до 11) из 6 элементов, определить количество отрицательных, нулевых и положитльных элементов. 2.
Ответы (1)