Задать вопрос
26 апреля, 01:43

Напишите программу, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее арифметическое

в Pascal

+3
Ответы (1)
  1. 26 апреля, 03:30
    0
    Program Lemonly;

    const

    n=10;

    var

    table: array [1 ... n] of real;

    i: integer;

    sum, arifm: real;

    begin

    randomize;

    sum:=0;

    writeln ('Введите ', n, ' чисел:') ;

    for i: = 1 to n do

    begin

    readln (table[i]) ;

    sum:=sum+table[i];

    end;

    writeln () ;

    arifm:=sum/n;

    writeln ('Cреднее арифметическое введённых чисел равно ', arifm:8:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее арифметическое в Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая вводила бы с клавиатуры значения времени и скорости, вычисляла бы пройденный путь. в Pascal
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
1. На входе непустая последовательность натуральных чисел с нулем в конце. Вывести MIN и среднее арифметическое. Представить блок-схему и pascal-программу. 2. На входе последовательность вещественных чисел с нулем в конце.
Ответы (1)
Помогите написать программы ... Задача 1 Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры Задача 2 Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран Задача 3
Ответы (1)