Задать вопрос
27 декабря, 20:56

Помогите написать программу в паскале и подробно описать

Присвойте z значение большего из x и y в том случае если x=0

+1
Ответы (1)
  1. 28 декабря, 00:30
    0
    Var x, y, z:integer; {описание переменных и их типа}

    begin

    writeln ('введи два числа') ; {Вывод на экран сообщения-подсказки}

    readln (x, y) ; {считывание переменных}

    if x<0 then {проверка условия.}

    if y>x then z:=y {если условие истинно, то мы ищем большее из х и у. если у больше, то присваиваем z значение у}

    else z:=x {если же больше х, то присваиваем его значение}

    else {если условие ложно}

    if y>x then z:=x {то мы ищем меньшее из х и у. если у больше, то присваиваем z значение х}

    else z:=y; {если же больше х, то присваиваем значение у}

    writeln (z) ; {вывод результата на экран}

    end. {конец программы}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале и подробно описать Присвойте z значение большего из x и y в том случае если x=0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 какие значения примут переменные х и у после выполнения последовательности команд? х=3 у=3 х=у у=х+2. 2. Объявите переменные Х, У и Z. Присвойте переменной Х значение 10, переменной У значение 15. Присвойте переменной Z сумму Х и У.
Ответы (1)
Написать программу на паскале Если данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел.
Ответы (1)
Даны три числа a, b, c. Значение большего из них присвойте значение d На паскале
Ответы (1)
Запишите на языке Паскаль логическое выражение, имеющее значение true при выполнении указанного условия и false в противном случае. Результат вычисления выражения присвойте логической пере - менной F.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)