Задать вопрос
29 февраля, 07:04

Найти произведение элементов линейного массива целых чисел m (n) удовлетворяющее условию m[i]=2*m[i+1]

+1
Ответы (1)
  1. 29 февраля, 08:56
    0
    Program qq;

    uses crt;

    var pr, i, n: integer; a:array[1 ... 32] of integer;

    begin

    randomize;

    writeln ('Введите количество элементов в массиве:') ;

    readln (n) ;

    for i:=1 to n do

    begin

    a[i]:=random (10) + 1;

    write (a[i], ' ') ; / / Распечатаем массив для наглядности

    end;

    pr:=1; / / Обнулить переменную мы не можем, ибо у нас произведение. Единица же, как начальный множитель нашего произведения, его "обнулит", но качественно ни на что далее не повлияет

    for i:=1 to n do

    if a[i]=2*a[i+1] then pr:=pr*a[i]; / / Если выполняется условие, то умножаем уже полученное произведение на элемент массива

    writeln;

    writeln (pr) ; / / выводим произведение на экран

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение элементов линейного массива целых чисел m (n) удовлетворяющее условию m[i]=2*m[i+1] ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)