Задать вопрос
22 сентября, 10:48

Напишите программу на языке Паскаль, для решения следующей задачи:

Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры).

(Подсказка. Используйте тип данных integer и операции div и mod)

+4
Ответы (2)
  1. 22 сентября, 13:00
    0
    Var a, b, c:integer;

    begin

    read (c) ;

    a:=c div 100; a:=a mod 10;

    b:=c div 10; b:=b mod 100;

    write (a+b) ;

    end.
  2. 22 сентября, 14:25
    0
    Var a, b, c, d:integer;

    begin

    readln (a) ;

    b: = (a div 100) mod 10;

    c: = (a mod 100) div 10;

    d:=b+c;

    writeln (d) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке Паскаль, для решения следующей задачи: Для любого четырехзначного вводимого числа найти сумму второй и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике