Задать вопрос
16 июня, 06:28

1) Выписать цифры числа n, если эти цифры >=4 и <=8

2) Найти сумму цифр числа n, если цифры >=4, но <=8

pascal abc

+1
Ответы (1)
  1. 16 июня, 07:48
    0
    Var n, m, p, s:integer;

    begin

    write ('n=') ;

    readln (n) ;

    m:=n; k:=0;

    write ('цифры, которые >=4 и <=8 : ') ;

    while m0 do begin

    p:=m mod 10;

    m:=m div 10;

    if (p>=4) and (p<=8) then begin

    write (p,' ') ;

    s:=s+p;

    end;

    end;

    writeln;

    writeln ('сумма этих цифр = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Выписать цифры числа n, если эти цифры >=4 и =4, но ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 2 двузначных числа, если 1 цифра 1 числа больше 1 цифры 2 числа и 2 ц3 ифра 1 числа меньше 2 цифры 2 числа, то вывсти на экран "да" иначе "нет"
Ответы (1)
В паскале я написал программу что бы 3 значное число разбилось на единицы, десятки и сотни, а потом написал что бы эти 3 цифры перемножились, а он перемножает не только эти 3 цифры, но и цифры 10 и 100 которые я использовал что бы разбить число на
Ответы (2)
Задание следующего плана: 1) Заполнить числами типизированный файл; 2) Считать эти цифры в байтах; 3) Вывести эти цифры в другой файл. txt; Вот код, который я написал, но не выводятся цифры.
Ответы (1)
Действие компьютерного вируса состоит в том, что вместо букв "б", "в", "л", "о", "т" печатаются цифры, причём разным буквам соответствуют разные цифры кроме цифры 0 причем разным буквам соответствуют разные цифры.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)