Задать вопрос
28 апреля, 17:41

Составить программу для определения, является ли натуральное число k степенью числа 3

Borland c

+2
Ответы (1)
  1. 28 апреля, 18:45
    0
    На С + + думаю что то же, что и на С

    #include

    #include

    using namespace std;

    int main () {

    int n;

    cin>>n;

    while (n>2) { n=n/3; }

    if (n==1) {cout<<"YES"; } else

    cout<<"NO"; }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для определения, является ли натуральное число k степенью числа 3 Borland c ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить с помощью Borland C Для целого числа k от 1 до 99 напечатать фразу "Мне k лет", учитывая при этом, что при некоторых значениях k слово "лет" надо заменить на слово "год" или "года". Например, 11 лет, 22 года, 51 год.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
С помощью датчика случайных чисел получить 15 вещественных чисел n, (38 < n < 39) Задача в borland pascal
Ответы (1)
Задание на Borland Pascal Пусть в программе объявлены переменные: d:real Определите тип следующего выражения: d+1
Ответы (1)
Помогите составить программу на языке Паскаль! Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!
Ответы (1)