Задать вопрос
22 марта, 03:59

Найдите сумму цифр четырёхзначного числа 1234 на языке паскаль.

+4
Ответы (1)
  1. 22 марта, 06:07
    0
    Var a, b, c, d, x:integer;

    begin

    x:=1234;

    a:=x mod 10;

    b: = ((x mod 100) div 10) ;

    c: = ((x mod 1000) div 100) ;

    d:=x div 1000;

    x:=a+b+c+d;

    writeln (x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите сумму цифр четырёхзначного числа 1234 на языке паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите решить задачу информатика-паскаль (програмирование) Дано целое положительное четырехзначнгое число. Напишите программу, позволяющую определить сумму двух первых цифр заданного четырехзначного числа. Например 1234 - 3
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)