Задать вопрос
27 октября, 13:27

Pascal (Паскаль). Очень прошу помощи

Составить программу сортировки массива методом пузырька НО не использовать for

Только через repeat + использовать flag

Всего в программе должно быть 3 переменных: i, flag, b:integer;

Заранее благодарен, тому кто поможет свяжусь и отблагодарю отдельно

+1
Ответы (1)
  1. 27 октября, 13:36
    0
    Program test;

    const n = 5;

    var i, flag, b:integer;

    m:array [1 ... n] of integer;

    begin

    b:=1;

    for i:=1 to n do

    readln (m[i]) ;

    repeat

    b:=b+1;

    if m[b]
    begin

    flag:=m[b-1];

    m[b-1]:=m[b];

    m[b]:=flag;

    b:=1;

    end;

    until b=n;

    for i:=1 to n do

    writeln (i,') ', m[i]) ;

    end.

    P. S. я использую for только для записи и вывода
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal (Паскаль). Очень прошу помощи Составить программу сортировки массива методом пузырька НО не использовать for Только через repeat + ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Приведенный фрагмент программы ... Паскаль //i, n, flag - переменные целого типа flag : = 1; if n > 2 then begin flag : = 0; for i : = 2 to n - 1 do begin if n mod i = 0 then begin flag : = 1; break end; end; end; writeln ((n = 2) OR (flag = 0)) ;
Ответы (1)
Переведите программу в Free Pascal var A: Array [1 ... 100] of integer; size: integer; Even: integer; notEven: integer; begin Write ('Set size A : ') ; Read (size) ; for i:integer : = 1 to size do begin Write ('Set A[', i, ']: ') ; Read (A[i]) ; end;
Ответы (2)
Определить значение переменной у после выполнения следующих фрагментов программы: a) Var у : real; i : integer; у : = 1; i : = 5; while i> 2 do i: = i - 1; y:=y + 1 * i; b) Var у : real; i : integer; у : = 1; i : = 2; repeat i: = 2 * i;
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)