Задать вопрос
3 июля, 06:42

Задачи на массив в Turbo Pascal

1) Определите, на сколько отличается рост самого высокого и самого низкого учащегося в классе?

2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива - год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.

3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура

+5
Ответы (1)
  1. 3 июля, 08:44
    0
    Program gt;

    var n, i, max, min:integer;

    a:array[1 ... 100]of integer;

    begin

    read (n) ;

    {n-кол-во учащихся}

    for i:=1 to n do

    read (a[i]) ;

    max:=a[1];

    min:=a[1];

    for i:=1 to n do

    begin

    if (a[i]>max) then max:=a[i];

    if (a[i]
    end;

    writeln (max,' ', min,'-росты')

    max:=max-min;

    writeln (max) ;

    end.

    2)

    program gt;

    var n, i, a, k:integer;

    begin

    read (n) ;

    k:=0;

    for i:=1 to n do

    begin

    read (a) ;

    if (a<1958) then k:=k+1;

    end;

    writeln (k) ;

    end.

    3)

    program gt;

    var i, q, a, l:integer;

    begin

    for i:=8 to 20 do

    begin

    read (a) ;

    if (a<0) then begin

    q:=q+1;

    if (q=1) then l:=i;

    end;

    end;

    writeln (l) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задачи на массив в Turbo Pascal 1) Определите, на сколько отличается рост самого высокого и самого низкого учащегося в классе? 2) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. известно что в течении этого времени температура понижалась.
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
В массиве хранятся сведения о росте 30 человек. Заполнить массив, если известно, что рост самого высокого равен 205 см, а самого низкого - 150 см. Найти средний рост.
Ответы (1)
1. Описать массив, подходящий для представления роста (в см) призывников в РА из 115 группы. 2. Написать программу, заполняющую массив данными (не упорядоченными) с клавиатуры и печатающую средний рост призывников. 3.
Ответы (1)
Какие из утверждений о памяти компьютера верны? 1. в памяти компьютера данные хранятся без определенного порядка 2. ёмкость памяти - это скорость доступа к ячейке памяти 3. память компьютера - устройство для хранения информации 4.
Ответы (1)