Задать вопрос
16 февраля, 11:28

В массиве, состоящем из 10-ти целых чисел, найти количество элементов, больше среднего арифметического элементов этого массива.

+2
Ответы (1)
  1. 16 февраля, 13:46
    0
    Var a:array[1 ... 10] of real; i, j, m:integer; n:real;

    begin

    n:=0;

    m:=0;

    for i:=1 to 10 do

    begin

    readln (a[i]) ;

    n:=n+a[i];

    end;

    n:=n/10;

    for j:=1 to 10 do

    begin

    if (a[j]>n) then m:=m+1;

    end;

    writeln (m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве, состоящем из 10-ти целых чисел, найти количество элементов, больше среднего арифметического элементов этого массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Найти сумму всех элементов массива целых чисел, которые меньше среднего арифметического элементов массива. Размерность массива-20. Заполнение массива осуществить случайными числами от 150 до 300
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)