Задать вопрос
30 января, 02:18

Даны два целых числа М и К (Integer для ABC Pascal). Если они оба неотрицательны, то умножить их на 10. Если неотрицательно одно из них, то умножить их на 100. Если они оба отрицательны, то умножить их на 1000.

Пример: 8,7 результат 80,70

-2,3 результат-200,300

+3
Ответы (1)
  1. 30 января, 04:09
    0
    Program n_1;

    var m, k: integer;

    begin

    if (m>0) and (k>0) then

    begin

    m:=m*10;

    k:=k*10;

    end;

    if ((m>0) and (k<0)) or ((m0) then

    begin

    m:=m*100;

    k:=k*100;

    end;

    if (m<0) and (k<0) then

    begin

    m:=m*1000;

    k:=k*1000;

    end;

    writeln (m) ;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два целых числа М и К (Integer для ABC Pascal). Если они оба неотрицательны, то умножить их на 10. Если неотрицательно одно из них, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Переведите программу в Free Pascal var A: Array [1 ... 100] of integer; size: integer; Even: integer; notEven: integer; begin Write ('Set size A : ') ; Read (size) ; for i:integer : = 1 to size do begin Write ('Set A[', i, ']: ') ; Read (A[i]) ; end;
Ответы (2)
Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.
Ответы (1)
можете объяснить за что отвечает xsearch? program c4; var n: integer; x, y: integer; xmin, xmax: integer; xsearch: boolean; ymin, ymax: integer; i: integer; s: real; begin xsearch : = true; xmin : = 0; xmax : = 0; ymin:=0; ymax : = 0; readln (n) ;
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите программу в Паскале по условию Даны действительные числа x, y. Если х, у отрицательны, то каждое значение заменить его модулем; если отрицательное только одно из них, то оба значения увеличить на 27;
Ответы (1)