Задать вопрос
17 мая, 14:51

Составить алгоритм поиска четырёхзначного числа, начинающегося с единицы и такого, что если переставить эту цифру в конец записи числа, то получится число, в три раза большее искомого. (на СИ)

+1
Ответы (1)
  1. 17 мая, 15:54
    0
    var x, y, z:Integer;

    begin

    for x:=1 to 9 do

    for y:=0 to 9 do

    for z:=0 to 9 do

    if 3 * (1000+x*100+y*10+z) = x*1000+y*100+z*10+1 then Writeln (1, x, y, z) ;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм поиска четырёхзначного числа, начинающегося с единицы и такого, что если переставить эту цифру в конец записи числа, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом. 1) Строится двоичная запись числа N.
Ответы (1)
Логическое "ИЛИ" называется? 1. логическая связка для поиска всех других слов, кроме указанного в запросе 2. логическая связка для поиска по всем словам 3. логическая связка для поиска по любому из слов Ответ:
Ответы (1)
6. Некоторый алгоритм из одного числа получает новое число следующим образом. Сначала записывается исходное число, а затем к нему приписываются цифры исходного числа в обратном порядке, а в конец числа дописывается столько единиц, сколько нечётных
Ответы (1)
Шестизначное число оканчивается цифрой 4. Если эту цифру переставить из конца числа в начало, то есть приписать ее перед первой, не изменяя порядка остальных пяти, то получится число, которое в четыре раза больше первоначального. Найти это число.
Ответы (1)
Алгоритм выполнения домашнего задания. Алгоритм рецепта приготовления пирога. Алгоритм мытья посуды. Алгоритм путешествия Колобка в известной сказке. Оформление.
Ответы (1)