Задать вопрос
14 сентября, 01:01

В массиве из 5 элементов, заданных с клавиатуры, найдите разность между наибольшим и наименьшим элементом (pascal abc)

+5
Ответы (2)
  1. 14 сентября, 01:43
    0
    var

    a: array[1 ... 5] of integer;

    i, z, x: integer;

    begin

    z : = - 1;

    x:=1;

    for i : = 1 to 5 do

    begin

    read (a[i]) ;

    if (a[i] >z) then z : = a[i];

    if (a[i]
    end;

    writeln (z - x) ;

    end.
  2. 14 сентября, 04:08
    0
    Ты поддерживаешь переменные min и max для хранения наибольшего и наименьшего элементов массива. Когда ты вводишь элемент, ты проверяешь - если введённый элемент больше наибольшего, ты обновляешь наибольший. Если введённый элемент меньше наименьшего, ты обновляешь наименьший.

    Важно задать min и max такие начальные значения, чтобы наибольший и наименьший элементы посчитались правильно. Для этого max нужно присвоить настолько большое значение, что при проверке задачи его не будут вводить. Для min нужно задать очень маленькое значение, которое тоже гарантированно не будет введено. Обычно диапазон вводимых чисел оговаривается в условии.

    Код

    var

    a: array[1 ... 5] of integer;

    i, max, min: integer;

    begin

    max : = - 32000;

    min : = 32000;

    for i : = 1 to 5 do

    begin

    read (a[i]) ;

    if a[i] > max then max : = a[i];

    if a[i] < min then min : = a[i];

    end;

    writeln (max - min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве из 5 элементов, заданных с клавиатуры, найдите разность между наибольшим и наименьшим элементом (pascal abc) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Всё сделать в программе PascalABC Задача №1 С клавиатуры вводится число n. Заполнить n элементов массива числами 2,4,8,16 ... и вывести массив. В массиве может находить не более 100 элементов. Задача №2 С клавиатуры вводится число n.
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)