Задать вопрос
4 апреля, 19:48

Какое число будет выведено на экран компьютера в результате выполнения фрагмента программы?

a:=6; b:=9;

If (b/3>=a-2) or (a*2>b) then

Begin b:=b*a;

a: = (b-3) / (a+11) ;

end

Else

Begin b:=a*b;

a:=b+a;

end;

Writeln (a) ;

+4
Ответы (1)
  1. 4 апреля, 22:57
    0
    If (b/3>=a-2) or (a*2>b)

    9/3=6-2. Условие выполняется, значит, делаем алгоритм после then

    b:=9*6=54

    a:=51/17=3

    Hyжно вывести число а, поэтому

    Ответ: 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Какое число будет выведено на экран компьютера в результате выполнения фрагмента программы? a:=6; b:=9; If (b/3>=a-2) or (a*2>b) then Begin ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Имеется условный оператор:if D10 then writeln ('ура!') else writeln ('плохо ...') ; Какими операторами его можно заменить? Выберите несколько из 4 вариантов ответа: 1) if D=10 then writeln ('ура!') else writeln ('плохо ...
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
Задание Определить без компьютера, что будет напечатано при выполнении следующих фрагментов программ: 1. k:=20; k:=k+10; if k+1030 then k:=8 else k:=k-1; WriteLn (k) Ответ: 2. k:=20; k:=k+10; if k+10 = 30 then k:=8 else k:=k-1; WriteLn (k) Ответ: 3.
Ответы (2)