Задать вопрос
30 июня, 11:58

Дружественные числа - это два натуральных числа, таких, что сумма всех делителей одного числа (меньших самого этого числа) равна другому числу, и наоборот. Напишите программу, которая будет искать дружеские пары чисел до 100 000. Pascal

+3
Ответы (1)
  1. 30 июня, 12:58
    0
    Function sum_del (x: longint) : longint;

    var

    s, i: longint;

    begin

    s : = 0;

    for i : = 1 to x div 2 do

    if x mod i = 0 then

    s : = s + i;

    sum_del : = s;

    end;

    var

    i, s1, s2: longint;

    begin

    for i : = 1 to 100000 do

    begin

    s1 : = sum_del (i) ;

    s2 : = sum_del (s1) ;

    if (s2 = i) and (s1 < i) then

    writeln (s1, ' ', i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дружественные числа - это два натуральных числа, таких, что сумма всех делителей одного числа (меньших самого этого числа) равна другому ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
754 000 000 000 000 000 000 в нормализованной форме? 0,000 000 000 000 022 865 в нормализованной форме?
Ответы (1)
Сколько работает примерно серверов в мире 1) 100 000 2) 10 000 000 3) 1 000 000 000 4) 100 000 000 000
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)