Задать вопрос
29 октября, 17:10

Придумайте массив и исполните предложенный фрагмент программы. Сформулируйте соответствующую задачу. a:=f[1]; b:=f[2]; for i:=1 to 8 do f[1]: = f[i+2]; f[9]:=a; f[10]:=b;

+4
Ответы (1)
  1. 29 октября, 20:38
    0
    задача элементы массива переместить на 2 позиции назад, а первый и второй переместить на предпоследний и последний

    var a, b, i:integer;

    f:array[1 ... 10] of integer;

    begin

    for i:=1 to 10 do

    begin

    f[i]:=random (11) ;

    write (f[i],' ') ;

    end;

    a:=f[1]; b:=f[2]; for i:=1 to 8 do f[i]: = f[i+2]; f[9]:=a; f[10]:=b;

    writeln;

    for i:=1 to 10 do

    begin

    write (f[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Придумайте массив и исполните предложенный фрагмент программы. Сформулируйте соответствующую задачу. a:=f[1]; b:=f[2]; for i:=1 to 8 do ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дан фрагмент программы: For i: = 1 to 10 do begin Writeln ('Hello, world!') End Что выполняет данный фрагмент? 2) дан фрагмент программы: For i: = 1 to 15 do begin Writeln (i) End Что выполняет данный фрагмент?
Ответы (1)
1) Дан фрагмент линейного алгоритма. а:=8 b:=6+3*а а:=b/3*а Чему равно значение переменной а после его исполнения? Ваш ответ: 2) Исполните следующий фрагмент линейного алгоритм для а = х и b = y.
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
В-3 1) Опишите последовательность 10 целых чисел с помощью массива 2) Дан фрагмент программы: For i:=1 to 10 do a[i]:=sqr (i) - i; Определите элементы массива 3) Дан массив (см задание 2).
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)