Задать вопрос
15 мая, 19:00

Как в C + + написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. Я пишу, вроде всё правильно делаю, но программа выдает: "Hello, 0", чтобы я не вводила.

#include;

using namespace std;

int main () {

int name;

cout << "What is your name?";

cin >> name;

cout << "Hello," << name<< endl;

return 0;

}

+1
Ответы (2)
  1. 15 мая, 20:18
    0
    По порядку:

    1) Ты забыл подключить библиотеку (надо было наприсать

    #include)

    2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C + + - это string (Для ее использования необходимо ее подключить - #include)

    Итого

    #include

    #include

    using namespace std;

    int main () {

    string name;

    cout << "What is your name?";

    cin >> name;

    cout << "Hello, " << name<< endl;

    return 0;

    }
  2. 15 мая, 21:07
    0
    Достаточно массива char str[10] и не нужно ничего лишнего подключать, прежде чем переходить к из С++, стоить ознакомится со Си строками, тк это только удобная обертка
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как в C + + написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. Я пишу, вроде всё правильно делаю, но программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы