Задать вопрос
9 февраля, 07:47

Найти сумму кратных 6 чисел в столбцах двумерного массива 10 на 10. Паскаль

+5
Ответы (1)
  1. 9 февраля, 09:51
    0
    Const n=10;

    var a:array[1 ... n, 1 ... n] of integer;

    s:array[1 ... n] of integer;

    i, j:integer;

    begin

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (30) ;

    write (a[i, j]:4)

    end;

    writeln

    end;

    writeln;

    for i:=1 to n do

    for j:=1 to n do

    if a[i, j] mod 6 = 0 then

    s[j]:=s[j]+a[i, j];

    for i:=1 to n do

    if s[i]>0 then writeln ('В столбце ', i:2,' сумма чисел, кратных 6, равна: ', s[i])

    else writeln ('В столбце ', i:2,' нет чисел, кратных 6') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму кратных 6 чисел в столбцах двумерного массива 10 на 10. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)