Задать вопрос
13 сентября, 12:44

В результате выполнения фрагмента программы

while0 do begin

write (2 * (n mod 10) + 1) ;

n:=n div 10

end

на экране выведено число 13717. Укажите все числа, которые могли находиться в переменной n до выполнения этого цикла.

+3
Ответы (1)
  1. 13 сентября, 14:13
    0
    1) 716, 2 * 6 + 1 = 13, n = 71;

    2) 638, 2 * 8 + 1 = 17, n = 63;

    3) 386, 2 * 6 + 1 = 13, n = 38;

    4) 836, 2 * 6 + 1 = 13, n = 83.

    Вариант 2) дальше не рассматриваем.

    При втором прохождении цикла:

    1) 71, 2 * 1 + 1 = 3, n = 7;

    3) 38, 2 * 8 + 1 = 17, n = 3;

    4) 83, 2 * 3 + 1 = 7, n = 8.

    Варианты 1) и 3) отбрасываем.

    Проверяем, получится ли в варианте 4) число 17.

    4) 8, 2 * 8 + 1 = 17, n = 0 (цикл останавливаеся).

    Ответ: 4) 836.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В результате выполнения фрагмента программы while0 do begin write (2 * (n mod 10) + 1) ; n:=n div 10 end на экране выведено число 13717. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
Тест: Операторы целочисленной арифметики div и mod 1. Вычислите: 25 div 11 2.27 3 2 2. Вычислите: 64 div 9 1 7 6 3. Вычислите: (35 div 2) div 5 2 17 3 4. Вычислите: (78 div 5) mod 10 5 15 10 5. Вычислите: (25 mod 11) + (18 mod 7) 3 7 4 6.
Ответы (1)
1. Решите примеры 13 div 5 = 13 mod 5 = 5 div 5 = 5 mod 5 = 3 div 8 = 3 mod 8 = 10 div 6 mod 3 = 2. Определите результат выполнения следующих действий а) a:=1819; b: = (div (а, 100)) * 10 + 9 a: = mod (10*b - a),100) а = ? b = ?
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)