Задать вопрос
20 апреля, 03:43

С клавиатуры вводится 10 чисел. Определить среднее арифметтческое всех чисел, которые больше первого. (Паскаль)

+1
Ответы (1)
  1. 20 апреля, 05:30
    0
    var

    i, n, pol: integer; / / pol - количество положительных чисел, n - количество всех чисел

    a, s: real; / / a - вводимое число, s - сумма положительных чисел

    begin

    pol: = 0; / / обнуляем счетчик

    s: = 0;

    writeln ('Введите количество чисел') ;

    readln (n) ;

    for i: = 1 to n do

    begin

    writeln ('Введите число') ;

    readln (a) ;

    if a > 0 then

    begin

    s: = s + a;

    pol: = pol + 1;

    end;

    end;

    writeln ('Среднее арифметическое положительных чисел: ', s / pol) ; {среднее арифметическое равно сумме чисел делить на их количество}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится 10 чисел. Определить среднее арифметтческое всех чисел, которые больше первого. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Паскаль 5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 (значение a вводится с клавиатуры; b>=10) в) третьи степени всех целых чисел от a до 50 (значение a вводится с клавиатуры; a
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)