Задать вопрос
23 сентября, 09:25

Написать программу в паскале Автобус провозит 50 пассажиров. Из них 10 едут до первой станции, 20 - до второй, а остальные до конечной. стоимость билетов до каждой станции соответственно равна a, b, c. Определите сколько рейсов должен делать автобус. чтобы выручка составила К руб?

+3
Ответы (1)
  1. 23 сентября, 12:40
    0
    var a, b, c, k, d, e, g, h : integer;

    var f : integer;

    begin

    writeln ('Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел : ') ;

    readln (a, b, c) ;

    writeln ('Введите сколько рублей должна быть конечная выручка : ') ;

    readln (k) ;

    d : = 10*a;

    e : = 20*b;

    g : = 20*c;

    h : = d+e+g;

    f : = h div k;

    writeln (f, ' Рейсов нужно совершить нужно совершить.') ;

    end.

    Лог:

    Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел:

    1

    1

    1

    Введите сколько рублей должна быть конечная выручка:

    50

    1 Рейсов нужно совершить нужно совершить.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале Автобус провозит 50 пассажиров. Из них 10 едут до первой станции, 20 - до второй, а остальные до конечной. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решение для данной задачи: автобус провозит 50 пассажиров. Из них 10 едут до первой остановки, 20 - до второй, а остальные до конечной. Стоимость билетов до каждой станции соответственно равно a, b, c.
Ответы (1)
В театре билеты продаются по цене 30 руб и 40 руб. Всего в театре 12 рядов по 25 мест в каждом ряду. Общая стоимость всех билетов равна 10000 руб. Сколько билетов продаётся по 40 руб?
Ответы (1)
В продаже имеются следующие компьютерные устройства: Клавиатура 1200 руб. Джойстик 2100 руб. Сканер 2500 руб. Системный блок 25000 руб. Мышь 990 руб. Акустические колонки 2600 руб. Принтер 4500 руб. Монитор 4500 руб.
Ответы (1)
составьте программу в паскале, определяющую s - стоимость партии товара, состоящей из n единиц, если цена каждой единицы товара - c результат должен быть показан фарзой: Стоимость общей партии товара равна ... руб.
Ответы (1)
Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолёте три четверти пассажиров имеют билеты первого класса, стоимостью и X рублей за каждый.
Ответы (1)