Задать вопрос
16 августа, 17:08

Укажите наибольшее натуральное число, при вводе которого эта программа напечатает сначала 3, потом - 6. С объяснением

var x, L, M: integer;

begin

readln (x) ;

L:=0; M:=0;

while x > 0 do begin

L:=L + 1;

if (x mod 8) 0 then

M: = M + x mod 8;

x: = x div 8;

end;

writeln (L) ; write (M) ;

end.

+4
Ответы (1)
  1. 16 августа, 19:00
    0
    1) цикл проработает 3 раза, но деление на 8 произойдёт дважды

    2) идём восходящим методом. чтобы число было наибольшим, то нужно помножить наибольший остаток при последней итерации цикла, следовательно остатки в цикле будут 6. 0, 0

    теперь помножим 6 на 8 два раза

    получим следующую цепочку 6->48->384, следовательно 384 наибольшее такое число.

    Ответ: 384
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Укажите наибольшее натуральное число, при вводе которого эта программа напечатает сначала 3, потом - 6. С объяснением var x, L, M: integer; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Тест: Операторы целочисленной арифметики div и mod 1. Вычислите: 25 div 11 2.27 3 2 2. Вычислите: 64 div 9 1 7 6 3. Вычислите: (35 div 2) div 5 2 17 3 4. Вычислите: (78 div 5) mod 10 5 15 10 5. Вычислите: (25 mod 11) + (18 mod 7) 3 7 4 6.
Ответы (1)
1. Решите примеры 13 div 5 = 13 mod 5 = 5 div 5 = 5 mod 5 = 3 div 8 = 3 mod 8 = 10 div 6 mod 3 = 2. Определите результат выполнения следующих действий а) a:=1819; b: = (div (а, 100)) * 10 + 9 a: = mod (10*b - a),100) а = ? b = ?
Ответы (1)
Операции MOD и DIV можно выполнять только над целыми числами: a) A:=21 DIV 5=? b) A: = 2 MOD 3=? B: = 20 MOD 5=? B: = 36.0 MOD 6=? C: = 14 DIV 6.0=? C: = 81 DIV 0=? D: = 14 MOD 0=? D: = 38 DIV 6=? E: = 5 MOD 13 = ? E: = 3 DIV 2=?
Ответы (1)