Задать вопрос
24 сентября, 11:02

Написать программу сортировки массива по возрастанию из 10 случайных элементов.

+3
Ответы (1)
  1. 24 сентября, 11:14
    0
    programm name; uses crt; const n=15; var a: array [1 ... n] of integer; i, j, c:integer; begin randomize; for i:=1 to n do begin a[i]:=random (50) ; write (a[i]:n) ; end; for i:=1 to n do for j:=1 to n - 1 do if a[j]>a[j+1]; c:=a[j]; a[j]:=a[j+1]; a[j+1]:=c; end; writeln; writeln ('метод пузырька') ; writeln ('наименьший элемент', a[i]) ; for i=1 to n do write (a[j]:n) ; readln; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу сортировки массива по возрастанию из 10 случайных элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)