Задать вопрос
11 августа, 18:01

Ближайшая к дому булочная работает с 7.00 до 19.00 и закрывается на перерыв с 13.00 до 15.00. Хлебный магазин, расположенный дальше, работает с 8.00 до 20.00 и имеет перерыв с 14.00 до 16.00. С 8.00 до 24.00 хлеб можно купить в гастрономе, расположенном дальше, чем хлебный магазин и работающем без обеда. По времени на часах у пользователя определить, что лучше:

а) сходить в булочную, так как она открыта;

б) дойти до хлебного магазина;

в) съездить в гастроном;

г) сидеть дома, так как везде закрыто.

Время вводится следующим образом: часы целая часть числа, минуты дробная часть числа. Например, 14,25 14 часов 25 минут.

+4
Ответы (1)
  1. 11 августа, 18:31
    0
    var

    a: real;

    s: string;

    begin

    write ('Введите время: ') ;

    readln (a) ;

    if ((7<=a) and (a<=13)) or ((15<=a) and (a<=19)) then s : = 'сходить в булочную, так как она открыта'

    else if ((8<=a) and (a<=14)) or ((16<=a) and (a<=20)) then s : = 'дойти до хлебного магазина'

    else if (8<=a) and (a<=24) then s:='съездить в гастроном'

    else s:='сидеть дома, так как везде закрыто';

    write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ближайшая к дому булочная работает с 7.00 до 19.00 и закрывается на перерыв с 13.00 до 15.00. Хлебный магазин, расположенный дальше, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Бабы-Яги есть песочные часы на 7 минут и 24 минут и книга колдовских рецептов, в которой разные зелья варятся разное время.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Время на электронных часах записывается в виде двух чисел: часы (от 0 до 23) и минуты (от 0 до 59). Требуется написать программу, которая определяет, сколько раз на электронных часах за данный промежуток времени часы совпадали с минутами.
Ответы (1)
Написать задачу на языке PascalABC По одну сторону улицы находятся дома с нечетными номерами (1,3,5, ...), по другую сторону - четными (2,4,6, ...). Дом 1 находится напротив дома 2, дом 3 - напротив дома 4 и тд.
Ответы (1)