Задать вопрос
5 декабря, 02:12

Написать программу на Python:

1. Даны стороны треугольника: a, b, c. Вычислить косинусы углов по теореме косинусов: sqr (c) = sqr (a) + sqr (b) - 2ab*cos (alfa).

2. Дан радиус шара. Найти его объем.

+1
Ответы (1)
  1. 5 декабря, 04:53
    0
    from math import sqrt

    a = int (input ("a = "))

    b = int (input ("b = "))

    c = int (input ("c = "))

    CAB = (sqrt (c) - sqrt (a) - sqrt (b)) / (-2*a*b)

    CBA = (sqrt (a) - sqrt (b) - sqrt (c)) / (-2*b*c)

    ACB = (sqrt (b) - sqrt (a) - sqrt (c)) / (-2*a*c)

    print ("CAB = ", CAB)

    print ("CBA = ", CBA)

    print ("ACB = ", ACB)

    2)

    from math import sqrt

    r = int (input ("r = "))

    pi = 3.14

    c = 4 / 3

    V = c * pi * sqrt (r) * r

    print ("V = ", round (V, 2))
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Python: 1. Даны стороны треугольника: a, b, c. Вычислить косинусы углов по теореме косинусов: sqr (c) = sqr (a) + sqr ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запусти Паскаль и введи программу: var a, b, c:integer; begin a:=-26; b:=abs (a) ; writeln ('abs (-26) = ', b) ; c:=sqr (b) ; writeln ('sqr (b) = ', c) ; c:=sqr (b+b) ; writeln ('sqr (b+b) = ', c) ; end.
Ответы (2)
Запусти Паскаль и введи программу: var a, b, c:integer; begin a:=-49; b:=abs (a) ; writeln ('abs (-49) = ', b) ; c:=sqr (b) ; writeln ('sqr (b) = ', c) ; c:=sqr (b+b) ; writeln ('sqr (b+b) = ', c) ; end.
Ответы (2)
Где здесь ошибка? program P12; uses crt; var a, b, c:real; i, n:integer; function F (x:real) : real; begin f:=sqr (sqr (x)) + (sqr (x)) * x-8*x (sqr (x)) + 5*x-3-cos (2*x) ; end; begin clrscr; a:=0; b:=1; n:=20; for i:=1 to n do begin c: = (a+B) / 2;
Ответы (1)
Что напечатает следующая программа? program p3; var x, y:integer; procedure p1 (var a, b:integer) ; begin a:=sqr (a) ; b:=sqr (a) + a; end; procedure p2 (a, b:integer) ; begin a:=sqr (a) ; b:=sqr (b) + b; end; begin x:=2; y:=2; p1 (x, y) ;
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)