Задать вопрос
13 октября, 20:29

Паскаль

Написать программу для нахождения суммы большего и меньшего из трех чисел. Указание: для решения задачи использовать подпрограммы вычисления минимального и максимального для двух чисел.

Пример

на входе: 45 72 24

на выходе: 96

+2
Ответы (1)
  1. 13 октября, 22:39
    0
    Var

    a, b, c: integer;

    function min_3 (const a, b, c: integer) : integer;

    var

    local_min: integer;

    begin

    if (a < b) then

    local_min : = a

    else

    local_min : = b;

    if (c < local_min) then

    local_min : = c;

    Result : = local_min

    end;

    function max_3 (const a, b, c: integer) : integer;

    var

    local_max: integer;

    begin

    if (a > = b) then

    local_max : = a

    else

    local_max : = b;

    if (c > local_max) then

    local_max : = c;

    Result : = local_max;

    end;

    begin

    writeln ('Введите a, b, c - > ') ;

    readln (a, b, c) ;

    writeln ('Результат: ', min_3 (a, b, c) + max_3 (a, b, c), '.') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Написать программу для нахождения суммы большего и меньшего из трех чисел. Указание: для решения задачи использовать подпрограммы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике