Задать вопрос
6 июля, 12:24

Даны целые числа: а, b, и с. Возвести в квадрат те из них, которые положительны.

Входные данные : - 3; 5; -2

Выходные : - 3; 25; -2.

+1
Ответы (2)
  1. 6 июля, 13:15
    0
    Program n1;

    var a, b, c: integer;

    begin

    readln (a, b, c) ;

    if a>0 then write (a*a,' ') else write (a,' ') ;

    if b>0 then write (b*b,' ') else write (b,' ') ;

    if c>0 then write (c*c,' ') else write (c,' ') ;

    end.
  2. 6 июля, 13:57
    0
    Var f: text; s, d:string; i, n:integer; a:array of integer; BeginAssign (f,'c://q/t. txt') ; Reset (f) ; n:=3; setLength (a, n) ; While not eof (f) do begin readln (f, s) ; writeln (i:2,' ', s) ; end; Close (f) ; writeln; var arr : = s. Split ('; ') ; for i:=0 to n-1 do begina[i] : = strtoint (arr[i]) ; if a[i] > 0 then a[i]: = a[i] * a[i]; end;

    for i:=0 to n-1 dod: = d + inttostr (a[i]) + '; ';

    assign (f,'c://q/out. txt') ; rewrite (f) ; write (f, d) ; Close (f) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целые числа: а, b, и с. Возвести в квадрат те из них, которые положительны. Входные данные : - 3; 5; -2 Выходные : - 3; 25; -2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)