Задать вопрос
5 октября, 20:07

4. Напишите код программы, которая будет вычислять периметр фигуры.

Program Perimeter;

Var

Begin

Writeln

Readln

End.

+5
Ответы (1)
  1. 5 октября, 21:28
    0
    Uses crt;

    function f (a, b:real) : real;

    begin

    f:=sqrt (a*a+b*b)

    end;

    var ab, ac, dc, bd, g, p:real;

    begin

    clrscr;

    writeln ('Введите длины строн') ;

    write ('ab=') ; readln (ab) ;

    write ('ac=') ; readln (ac) ;

    write ('dc=') ; readln (dc) ;

    g:=f (ab, ac) ;

    bd:=f (g, dc) ;

    p:=ab+ac+dc+bd;

    write ('Периметр=', p:0:2) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Напишите код программы, которая будет вычислять периметр фигуры. Program Perimeter; Var Begin Writeln Readln End. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m') ; readln (c, m) ; s:=c*m; writeln ('s=', s) ; readln; end.
Ответы (1)
Что я неправильно написал? var a, b, c, d: real; begin writeln (' введи число a') ; readln (a) ; writeln ('введи число b') ; readln (b) ; writeln ('введи число c') ; readln (c) ; d:=a; a:=c; writeln (a) ; c:=b; writeln (c) ; b:=d; writeln (b) ; end.
Ответы (1)
Написать программу нахождения периметра параллелограмма по известным сторонам b и h (b и h - целые числа, вводимые с клавиатуры).
Ответы (1)
Выдаёт ошибку: операнды имеют неприводимые типы. Где я ошиблась? (Программа написана на языке Pascal ABC) Program Home; Uses CRT; Var a: integer; b: real; Begin WriteLn ('Введите еденицу измереня: килограмм, миллиграмм, грамм, тонна, центнер') ;
Ответы (1)